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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about this product, including instrument 
software upgrades, application information, and product information, browse to the following URL:

https://www.keysight.com/us/en/product/N5186A/N5186A.html

Information on preventing instrument damage can be found at:

http://keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. 
To search for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

http://www.keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/techsupport
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Basic Measurements
Overview

Overview
Keysight’s N5186A MXG is optimized to be your ideal signal generator with the 
outstanding performance you desire, all in one easy-to-use box capable of 
signal generation up to 8.5 GHz with 960 MHz of modulation bandwidth per 
channel.

The measurement examples use an X-Series Signal Analyzer to view the 
results. For information on using the Signal Analyzer multi-touch user 
interface, refer to the Online Help.

Please refer to the MXG data sheet and signal analyzer data sheet to 
ensure your measurement setup has adequate power. 

https://www.keysight.com/us/en/product/N5186A/N5186A.html

The software versions used in this measurement guide are:

— MXG: A.13.01

— Signal Analyzer/N9063EM0E: Version 2021 A.31.xx or later

— 89601 VSA: Version 2019
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Basic Measurements
Equipment Setup

Equipment Setup

— N5186A front panel RF 1 Out to N9032B front panel RF In

— N5186A rear panel Event 2 to N9032B rear panel Trig 1 In

— N5186A rear panel Ref Out to N9032B rear panel Ext Ref In
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Basic Measurements
Setting Up Triggers on the Signal Analyzer

Setting Up Triggers on the Signal Analyzer

1. From the Signal Analyzer Menu Panel (on the top right of the display), 
select Mode/Meas > Spectrum Analyzer mode. 

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the dropdown on the top right, select Trigger and set Trigger Source 
to Free Run. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Basic Measurements
Making Measurements

Making Measurements

Creating a Continuous Waveform (CW)

This procedure will demonstrate the amplitude and frequency accuracy of the 
MXG.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area, set Frequency to 1 GHz and Power to 0 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the 
corresponding RF Output Block.

3. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

4. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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Basic Measurements
Making Measurements

2. From the Menu Panel, select Frequency and set Center Frequency to 
1 GHz and Span to 1 MHz.

3. Select Peak Search.

Observe the accuracy of the amplitude and frequency of the signal.

On the MXG:

1. Set Output 1 Power to –90 dBm.

2. Ensure that RF Out is On.

On the Signal Analyzer: 

1. Select Amplitude and set Ref Level to –70 dBm and Scale/Div 5 dB.

2. Select BW and set Video BW to 300 Hz.

3. Select Peak Search. 
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Making Measurements

Observe the frequency and amplitude accuracy of the MXG at low power 
levels.

On the MXG:

1. Set Frequency to 8 GHz and Power to 0 dBm.

On the Signal Analyzer:

1. Select Frequency and set Center Frequency to 8 GHz.

2. Select Amplitude and set Ref Level to 0 dBm and Scale/Div to 
10 dB. 

3. Select BW > Video BW and set to Auto.

4. Select Peak Search.



14                                                                                                N5186A MXG and X-Series SA Measurement Guide
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Observe the frequency and amplitude accuracy at higher frequency levels.
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Making Measurements

Using the equivalent SCPI commands

Creating a CW signal on Channel 1.

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude 0dBm

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:

FREQuency:CENTer 1GHZ

FREQuency:SPAN 1MHZ

CALCulate:MARKer1:MAXimum

On the MXG:

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude -90dBm

RF1:OUTPut:STATe ON

On the Signal Analyzer:

DISPlay:WINDow1:TRACe:Y:RLEVel -70

DISPlay:WINDow1:TRACe:Y:PDIVision 5

BWIDth:VIDeo 300Hz

CALCulate:MARKer1:MAXimum

On the MXG:

RF1:FREQuency:CW 8GHZ

RF1:POWer:AMPLitude 0dBm

On the Signal Analyzer:

FREQuency:CENTer 8GHZ

DISPlay:WINDow1:TRACe:Y:RLEVel 0

DISPlay:WINDow1:TRACe:Y:PDIVision 10

BANDwidth:VIDeo:AUTO ON

CALCulate:MARKer1:MAXimum
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Setting Up Amplitude Modulation 

Follow the steps below for AM analog modulation using the internal I/Q 
modulation source.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 6 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

The MXG must have the E7642APPC PathWave Signal Generation for IQ 
Based AM, FM, and Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.
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Basic Measurements
Making Measurements

4. From the Mode dropdown, select Analog Modulation.

5. Select the Analog Modulation tab and set:

a. Modulation Type to AM.

b. Waveform to Sine.

c. Rate to 100 kHz.

d. Depth to 50%.
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Basic Measurements
Making Measurements

6. Select the General tab > Enable.

Selecting Enable automatically turns on both Output Modulation and 
Internal I/Q Modulation as displayed in the Output Modulation block.

7. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

8. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

On the Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 6 GHz and Span to 
500 kHz.



N5186A MXG and X-Series SA Measurement Guide                                                                                   19

Basic Measurements
Making Measurements

3. Select BW and set Res BW to 100 Hz.

4. Select Peak Search.

5. Use markers to measure sideband power relative to the center frequency 
by selecting Marker Delta. Select Next Pk Right until the second marker is 
at the next highest peak. 

The Delta Marker should be approximately –12 dB for 50% AM. 
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Making Measurements

Using the equivalent SCPI commands

On The MXG:

SYSTem:PRESet

RF1:FREQuency:CW 6GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE AM

SIGNal1:AM:SHAPe SINE

SIGNal1:AM:FREQuency 100KHZ

SIGNal1:AM 50

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:

FREQuency:CENTer 6GHZ

FREQuency:SPAN 500KHZ

BANDwidth 100 Hz

CALCulate:MARKer1:MODE DELTa

CALCulate:MARKer1:MAXimum:RIGHt

Repeat the above command until the marker is at the next highest peak.

To retrieve the delta marker:

CALCulate:MARKer1:Y?
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Basic Measurements
Making Measurements

Setting Up Frequency Modulation

Follow the steps below for FM analog modulation using the internal I/Q 
modulation source.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 6 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

4. From the Mode dropdown, select Analog Modulation.

5. From the left pane, select the Analog Modulation tab and set:

a. Modulation Type to FM.

The MXG must have the E7642APPC PathWave Signal Generation for IQ 
Based AM, FM, and Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.
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Basic Measurements
Making Measurements

b. Waveform to Sine.

c. Rate to 400 Hz.

d. Deviation to 10 MHz.

6. Select the General tab > Enable.

Selecting Enable automatically turns on both Output Modulation and 
Internal I/Q Modulation as displayed in the Output Modulation block.

7. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

8. Set RF Out to On by selecting the numbered channel indicator switch. 
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Basic Measurements
Making Measurements

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

On the Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 6 GHz and Span to 
50 MHz.

3. Select BW and set Res BW to 240 Hz.

Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 6GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE FM

SIGNal1:FM:SHAPe SINE

SIGNal1:FM:FREQuency 400HZ

SIGNal1:FM 10MHZ



24                                                                                                N5186A MXG and X-Series SA Measurement Guide

Basic Measurements
Making Measurements

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:

FREQuency:CENTer 6GHZ

FREQuency:SPAN 50MHZ

ACPower:BANDwidth 240 Hz
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Basic Measurements
Making Measurements

Setting Up Phase Modulation

Follow the steps below for PM analog modulation using the internal I/Q 
modulation source.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 6 GHz and Amplitude to 0 dBm.

3. Select the Signal block to open.

4. Select the Mode dropdown and select Analog Modulation.

The MXG must have the E7642APPC PathWave Signal Generation for IQ 
Based AM, FM, and Phase license installed. The X-Series Analyzer must 
have N9063EM0E Analog Demodulation Measurement license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.
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Basic Measurements
Making Measurements

5. From the left pane, select the Analog Modulation tab and set:

a. Modulation Type to PM.

b. Waveform to Sine.

c. Rate to 10 kHz.

d. Deviation to 1 rad.

6. Select the General tab > Enable.

7. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

8. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.
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Basic Measurements
Making Measurements

On the Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Analog Demod mode > PM Measurement > Quad View.

2.  Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 6 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 6GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE PM

SIGNal1:PM:SHAPe SINE

SIGNal1:PM:FREQuency 10KHZ

SIGNal1:PM 1

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:

INSTrument:CONFigure:ADEMOD:PM

SYSTem:PRESet

DISPlay:VIEW:ADVanced:SELect "QUAD"

FREQuency:CENTer 6GHZ



N5186A MXG and X-Series SA Measurement Guide                                                                                   29

Basic Measurements
Making Measurements

Setting Up a Multitone Signal

This example shows you how to create a multitone signal, which allows you to 
separate the usable frequency band into multiple channels. This can make a 
signal that is difficult to characterize in the time domain more readable.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 6 GHz and Amplitude to -10 dBm.

3. Select the Signal block to open.

4. Select the Mode dropdown and select Multitone.

5. Select the Multitone tab and set: 

a. Set Tones to 15 >x1.

The MXG must have the E7621APPC PathWave Signal Generation for 
Multitone license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.
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b. Set Tone Spacing to 15 MHz.

6. Select the General tab > Enable.

7. Close the Vector Modulation Signal Setup selecting the Home icon at the 
top of the display. 

8. Ensure that RF Out is On.

On the Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 6 GHz and Span to 
250 MHz.

3. Select BW and set Res BW to 30 kHz.

Observe the 15 tones.
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Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 6GHZ

RF1:POWer:AMPLitude -10dBm

SIGNal1:MODE MTONes

SIGNal1:MTONe:ARB:NTON 15

SIGNal1:MTONe:ARB:FSP 15MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:
Change to Spectrum Analyzer mode, Swept SA measurement.

INSTrument:CONFigure:SA:SAN

DISPlay:VIEW:ADVanced:SELect “NORMAL”

FREQuency:CENTer 6GHZ

FREQuency:SPAN 250MHZ

BANDwidth:RESolution 30KHZ
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Setting Up Waveform File Vector Modulation

In this section, we will load a GSM and a WCDMA waveform into the MXG to 
demonstrate the accuracy of the MXG’s vector modulation.

The MXG supports all ARB waveforms that are provided on the X-Series 
sources. This section will use a few of the ARB files that come with the X-Series 
sources.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 6 GHz and Amplitude to 0 dBm.

3. Select the Signal block to open.

4. In the Vector Modulation Signal Setup:

a. Set Mode to Waveform File.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer” on page 10.
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b. In the left panel, select the Waveform File tab.

c. Use File Select to navigate to the Waveforms folder.

d. Select the Up arrow icon to access the Examples folder. 

e. Open the Examples folder and highlight 
GSM_1C_BURST_SECUREWAVE.wfm, then Select. 
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f. Select the General tab > Enable.

5. Select the Home icon and ensure that RF Out is on.

On the Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 6 GHz and Span to 
900 kHz.

3. Select BW and set Res BW to 470 Hz.

4. Select Trace and set Trace Type to Max Hold.

5. Observe the GSM signal. 
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On the MXG:

1. Select the Signal block to open the Vector Modulation Signal Setup.

2. From the Waveform tab on the left side of the display, choose File Select 
to navigate to the Waveforms folder.

3. Select the Up arrow icon to access the Examples folder. 

4. Open the Examples folder and highlight WCDMA_TM1_64DPCH_4C.wfm, 
then Select. 
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5. Select the General tab > Enable.

6. Select the Home icon and ensure that RF Out is on.

On the Signal Analyzer:

1. Select BW and set Res BW to 620 Hz.

2. Select Frequency and set Center Frequency to 6 GHz and Span to 30 MHz.

3. Observe the WCDMA signal.
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Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 6GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGN1:WAV "/Examples/GSM_1C_Burst.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the Signal Analyzer:

FREQuency:CENTer 6GHZ

FREQuency:SPAN 900KHZ

ACPower:BANDwidth 470 Hz

DISPlay:TXPower:WINDow1:TRACe:MAXHold ON

On the MXG:

SIGN1:WAV "/Examples/WCDMA_TM1_64DPCH_4C.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

On the Signal Analyzer:

ACPower:BANDwidth 620 Hz

FREQuency:SPAN 30MHZ
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Using the N5186A as a Multifunction Generator

Introduction

A function generator is a type of signal generator that is used to generate 
various waveforms with adjustable parameters to generate complex signals. 
Keysight's Multifunction Generator option 303 and UNT, first seen on the 
N5171B, includes a slew of function generators which can output complex 
signals. These signals can either be output directly to the LF port or routed to 
the modulators, ultimately output through the RF port. When using the 
function generators for modulation, the adjustable parameters include 
modulation type, frequency, amplitude, and phase. Often used in the fields of 
prototyping, development, testing, and calibration especially in the context of 
communication systems. An accurate function generator can help engineers 
accelerate the research and design process to bring high performance designs 
to the market quicker. 

Supported Signal Generators with Option 303 and UNT

— N5171B

— N5172B

— N5173B

— N5181B

— N5182B

— N5183B

— N5185A

— N5186A

— M9484C

Theory of Operation

Multifunction generator N5186A Option 303 is a collection of six function 
generators that can be used independently or in parallel (up to five), ultimately 
being applied to the RF signal of choice or routed to the Low Frequency (LF) 
Output port. The LF Output port is designed to output low-frequency signals, 
making it ideal for directly using the function generators as well as measuring 
them. Ignoring the external function generator inputs (Ext 1 and Ext 2), there 
are six selectable function generators: Function Generator 1 (Func Gen 1), 
Function Generator 2 (Func Gen 2), Dual Function Generator (Dual Func Gen), 
Swept Function Generator (Swept Func Gen), Noise Generator 1 (Noise Gen 1), 
and Noise Generator 2 (Noise Gen 2).
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Figure 1-1 Multifunction Generator Block Diagram

In Figure 1-1, each function generator (except Noise Gen 1 and Noise Gen 2) 
can access six periodic waveforms (sine, triangle, square, positive ramp, 
negative ramp, and pulse), with controllable frequency and phase offset.

The six periodic waveforms are considered the "Basic Waveforms". The Basic 
Waveforms can be made more complex by combining them using the Dual 
Function, demonstrated in “Dual Function” on page 49. The Basic Waveforms 
can also be swept using the Swept Function, demonstrated in “Swept 
Function” on page 55.

The output of the function generators can be routed to the Amplitude 
Modulator and the Frequency/Phase modulator. A function generator can be 
assigned to each of the paths (AM1, AM2, FM1, FM2, ØM1, ØM2) which are 
summed and applied to the AM and FM/ØM modulators. The modulators are 
then applied to the RF output signal.

Figure 1-2 Function Generator Paths
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Using Multifunction Generator Option 303
Functions can be combined by summation and applied to modulations on the 
RF output. Modulation formats include AM, FM, and ØM. The LF port can be 
used to monitor the behavior of a single function generator that is being used 
by a modulator.

The multifunction generator's flexibility enables a wide range of configurations, 
catering to numerous testing applications. This adaptability ensures efficient 
and effective simulation of real-world scenarios for testing RF and LF designs. 
Ultimately, the multifunction generator enhances testing capabilities, allowing 
quicker problem solving.

Figure 1-3 Modulation Types
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Figure 1-4 LF Output

Figure 1-5 Basic Waveforms
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Multifunction Generator Demonstrations
An easy way to visualize the behavior of the internal function generators in the 
time domain is to use the LF Out port. By routing the function generator of 
choice to the LF Out, an Oscilloscope can capture its behavior. 

1. Select Preset > Preset to set the instrument to a known state.

2. Select the System menu > Connectors.

3. In the Connectors window, select LF Out.

4. In the LF Out window, set:

— Source to Function 1

— Shape to Sine

— Frequency to 1 kHz

— Amplitude to 1 V
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— LF Output On

5. Capture the signal on the oscilloscope.

6. On the MXG, change the shape to Triangle.
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7. Capture the signal on the oscilloscope.

8. On the MXG, change the shape to Ramp.

9. Capture the signal on the oscilloscope.
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10. Set the Ramp Polarity to Negative.

11. Capture the signal on the oscilloscope.
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12. Set Shape to Pulse and set Duty Cycle to 10%.

13. Capture the signal on the oscilloscope. 

14. Set the Shape to Square.

15. Capture the signal on the oscilloscope. 
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Special Function Generators
The list of available function generators that are included with Option 303 are:

— Function 1

— Function 

— Dual Function

— Noise 1

— Noise 2

— Swept function

 In the “Multifunction Generator Demonstrations” on page 43, the 
characteristics of function generators 1 and 2 are captured. Function 
generators such as Dual Function, Noise 1 & 2, and Swept Function have 
unique functions that can also be visualized using an oscilloscope and signal 
analyzer.

Dual Function

The Dual Function generator is similar to having both Function 1 and 
Function 2 operating at the same time, but with an adjustable phase offset. 
Providing precise control of phase difference between two functions.

An easy way to visualize the behavior of a dual function generator is by using 
an oscilloscope.

1. Select Preset > Preset to set the instrument to a known state.

2. Select the System menu > Connectors.

3. In the Connectors window, select LF Out.

4. In the LF Out window, set:

— Source to Dual Function1

— Amplitude to 1 V
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— Toggle LF Output On

5. Set Shape 2 to Square.

A simply way to demonstrate the phase relationship between functions is 
to set one to square and adjust the phase and monitor the output.

6. Capture the signal on an oscilloscope.
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You can see the Sine and Square waves are in phase.

7. In the LF Out window, change the Phase Offset 2 to 90 degrees.

8. Capture the signal on the oscilloscope.
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You can see the Sine and Square waves are 90 degrees out of phase.

9. Change the Phase Offset 2 to 180 degrees.

10. Capture the signal on the oscilloscope.
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The Sine and Square waves are 180 degrees out of phase.

Noise Generator

There are two noise generators (Noise 1 and Noise 2) that both provide the 
same functionality. The noise generators have selectable noise type (Uniform 
or Gaussian). Noise generators play a critical role in RF immunity testing, fault 
isolation testing, and many more. The noise generators can be routed to the LF 
port to observe their behavior.

1. Select Preset > Preset to set the instrument to a known state.

2. Select the System menu > Connectors.

3. In the Connectors window, select LF Out.

4. In the LF Out window, set:

— Source to Noise 1
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— Type to Uniform

— Amplitude to 500 mV

— DC Offset to 0

— Toggle LF Output On

5. Capture the signal on the oscilloscope

6. Set Type to Gaussian.
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7. Capture the signal on the oscilloscope

Swept Function

The Swept Function generator has a selectable start frequency, stop 
frequency, and sweep start to stop time as well as selectable sweep shape, 
sweep waveform shape, and trigger source. With a frequency range of 10 mHz 
to 10 MHz and a start-to-stop time range of 20 ns to 89 s. The Swept Function 
Generator is key in conducting frequency response testing for filters, 
amplifiers, and various other RF components. The Swept Function Generator 
can be routed to the LF port to observe it's behavior.

1. Select Preset > Preset to set the instrument to a known state.

2. Select the System menu > Connectors.

3. In the Connectors window, select LF Out.

4. In the LF Out window, set:
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— Source to Sweep Function

— Configure Sweep

5. Set:

— Start Frequency to 10 Hz

— Stop Frequency to 10 kHz

— Sweep Start to Stop Time to 1 s

6. Select the Back Arrow and select:

— LF Out

— Amplitude to 500 mV
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— Toggle LF Output On

7. Capture the signal on the oscilloscope

Sawtooth and Triangle Sweep Shapes

The Swept function generator has two selectable sweep shapes (Sawtooth and 
Triangle). The Sawtooth sweep shape is a linear sweep from start frequency to 
stop frequency. When the stop frequency is reached the function generator 
jumps back to the start frequency and repeats again. The Triangle waveform 
sweep shape starts at the start frequency then sweeps to the stop frequency, 
but when the stop frequency is reached the function generator sweeps back 
down in frequency until reaching the start frequency. This behavior is best seen 
on a spectrogram measurement.

1. Select Preset > Preset to set the instrument to a known state.
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2. Select the System menu > Connectors.

3. In the Connectors window, select LF Out.

4. In the LF Out window, set:

— Source to Sweep Function

— Configure Sweep

5. Set:

— Start Frequency to 1 MHz

— Stop Frequency to 1.5 MHz

— Sweep Start to Stop Time to 1 s
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— Sweep Shape to Sawtooth

6. Select the Back Arrow and select:

— Amplitude to 500 mV

— Toggle LF Output On
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7. Capture the signal on a Spectrogram.

8. Select Configure Sweep > Sweep Shape Triangle.

9. Select the Back Arrow and Toggle LF Output On.
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10.  Capture the signal on the Spectrogram.

The Triangle Sweep shape has two Sweep Start to Stop Time inputs, one for 
sweep up and one for sweep down. By changing the sweep times to be unequal, 
the sweep shape that is seen on the spectrogram will become nonuniform.

11. In the LF Output Sweep Configuration window, set Sweep Start to Stop 
Time to 300 ms and Sweep Start to Stop Time to 3s.
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12.  Capture the signal on the Spectrogram.

Notice that the signal sweeps from a low to high frequency at a faster rate than 
from a high to low frequency. 

Radio Frequency Modulation Option UNT

In the sections above the function generators were routed to the LF port to 
observe their operation individually. This section will demonstrate how Option 
303 effects the RF signal at the RF port. The function generators are used to 
modulate the RF signal through amplitude and frequency/phase modulators 
(see Figure 1-2 on page 40). We can see how the modulators affect the 
original RF signal in both time and frequency domain using a signal analyzer 
and oscilloscope.

Amplitude Modulation

Using an oscilloscope, amplitude modulation can be observed in the time 
domain. The function generators produce the modulating signal, creating the 
envelope, while the RF signal serves as the carrier wave.

To apply amplitude modulation:
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1. Select Preset > Preset to set the instrument to a known state and select 
the Out Mod block.

2. In the Output Mode window, select AM1 arrow at the far left side of the 
window.

3. In the AM1 window, set:

— Source to Function 1

— Frequency to 10 Hz

— Depth to Linear to 100%
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— Toggle AM 1 On

4. Select the Home icon and set:

— Frequency to 50 MHz

— Power to -10 dBm

— Toggle RF output On
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5. Capture the envelop on the oscilloscope. The shape of the function 
corresponds to the shape of the envelope. (In this example, the function 
shape is set to sine.)

6. Capture the carrier on the oscilloscope.
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You can also view the modulation on a spectrogram. The modulation can 
be visualized as varying intensity of the carrier frequency over time.

The shape of the function generator corresponds to the shape of the 
envelope when generating AM signals.

Frequency Modulation

Using a signal analyzer, frequency modulation can be observed using a 
spectrogram. The function generator produces the modulating signal, which 
varies the frequency of the RF signal. 

To apply frequency modulation:
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1. Select Preset > Preset to set the instrument to a known state and select 
the Out Mod block.

2. In the Output Mode window, select the right arrow at the bottom of the 
display to select choices 5-8, then select the FM1 arrow at the far left side 
of the window.

3. In the FM1 window, set:

— Source to Function 1

— Frequency to 1 Hz

— Deviation to 50 kHz
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— Toggle FM 1 On

4. Select the Home icon and set:

— Frequency to 50 MHz

— Power to -10 dBm

— Toggle RF output On
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5. Capture the signal on the Spectrogram.

The shape of the function generator corresponds to the shape of the 
frequency modulation.

Phase Modulation

Phase Modulation can be visualized using an Oscilloscope in the time domain. 
The function generator produces the modulating signal, which varies the phase 
of the RF signal.

To apply phase modulation:
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1. Select Preset > Preset to set the instrument to a known state and select 
the Out Mod block.

2. In the Output Mode window, select the right arrow at the bottom of the 
display to select choices 5-8, then select the PM1 arrow at the far left side 
of the window.

3. In the PM1 window, set:

— Source to Function 1

— Frequency to 10 MHz

— Deviation to 45 deg
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— Toggle PM 1 On

4. Select the Home icon and set:

— Frequency to 50 MHz

— Power to -10 dBm

— Toggle RF output On
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5. Capture the signal on the Oscilloscope.

Applications

In many scenarios a RF communication system is subject to dynamic 
environments which can alter the characteristics of an ideal signal. In an ideal 
environment, the signal being generated and transmitted is the exact signal 
being received. Physically we know that this is not possible, the signal will be 
subject to some change. Therefore, a good communication system is resilient 
and can operate effectively within some range of impairments.

Consider an environment where signal strength fluctuates over time due to 
varying physical obstructions between the source and receiver. It would be 
inefficient and inconsistent to physically implement a RF environment to test 
your communication system. A more effective and repeatable test would be to 
simulate the conditions of such an environment. Using AM, we can simulate 
the impairment of varying signal strength. With selectable frequency, shape, 
and depth the AM modulator is capable of a wide range of simulated 
environments to support signal strength testing.

One of the design challenges of mobile communications systems comes from 
Doppler shift. As a transmitter and receiver move towards or away from one 
another, the signal will compress or stretch, effectively changing the perceived 
frequency. An effective way to simulate such an environment is by using the FM 
modulator. Using FM, we can simulate the impairment of varying frequency 
caused by Doppler shift. With selectable frequency deviation and deviation 
rate, the FM modulator can effectively simulate Doppler shift environments 
that mobile communication systems often encounter.
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When in an environment that causes reflections, a wireless communication 
system will be subject to multipathing. Consider a communication system that 
operates in a major city. Large buildings made of concrete and glass windows 
create many reflections of the signal being sent. These reflections cause 
variation in phase with respect to the original signal. Using PM, we can 
simulate the impairment of phase variation caused by multipathing. With 
selectable phase deviation, deviation rate, and offset the PM modulator can 
effectively simulate a simple multipath environment caused by reflective 
surfaces.

Multifunction Generator Option 303 allows you to apply multiple impairments 
simultaneously. If needed, the function generators can be configured such that 
five impairments are applied at the same time. It is important to note that there 
are two paths per modulator, which means that no more than two functions 
can be applied to one modulation type. The FM/PM modulator can only do one 
modulation type at a time, meaning that PM and FM cannot run 
simultaneously. AM and FM or AM and PM can be summed, however.

Conclusion

Simulating RF environments using amplitude, frequency, and phase 
modulation provides a robust and repeatable method for testing 
communication systems. By leveraging these modulation techniques, 
engineers can effectively simulate real-world conditions such as fluctuating 
signal strength, Doppler shifts, and multipath reflections. This approach not 
only enhances the reliability of testing but also ensures that communication 
systems are resilient and capable of operating under various impairments. The 
Multifunction Generator Option 303 further extends this capability by allowing 
multiple impairments to be applied simultaneously, offering a comprehensive 
solution for thorough and efficient receiver testing. Through these simulation 
techniques, we can better prepare and design communication systems to 
perform reliably in dynamic and challenging environments.
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2 Corrections

— “Corrections/De-embedding Using PathWave E7653APPC Software” on 
page 76

— “Using a Spectrum Analyzer to Make the Corrections Measurement” 
on page 82

— “Using a Power Meter to Make the Corrections Measurement” on 
page 88

— “Adding Fixture Blocks using s2p Files” on page 76
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Corrections/De-embedding Using PathWave E7653APPC Software
De-embedding is used to remove the effects of test fixtures and cabling from 
the measurement results. De-embedding uses a model of the test fixture and 
mathematically removes the fixture characteristics (cables, connectors and 
other passive components) between the source and the device under test 
(DUT). Once the desired topology has been characterized, its effects can be 
removed from the output signal, moving the effective reference plane to the 
point at which the power sensor was connected. 

Blocks can be added from supported file formats (.s2p, .csv, .uflat) or by direct 
measurement, using one of the supported power sensors (power meter, 
spectrum analyzer, or a network analyzer). 

Adding Fixture Blocks using s2p Files

Amplitude and phase can be corrected by adding multiple s2p files as Fixture 
Blocks. 

An s2p file (also known as a Touchstone file) is an ASCII text file used for 
documenting the n-port network parameter data and noise data of linear 
active devices, passive filters, passive devices, or interconnect networks. Each 
record contains 1 stimulus value and 4 S-parameters (total of 9 values)

The first line in the figure below (# GHz DB R 50) designates:

— (GHz) designates the frequency in Hz, kHz, MHz, or GHz

— (S) the measurements are in S parameters (rather than Y or Z)

— (DB) the values are given in decibel/angle. Instead of DB, you can have RI 
(real/imaginary) or MA (magnitude/angle)

— (50) the characteristic impedance is 50 ohms

1. Create s2p files in Notepad in the format shown above.

The MXG must have the E7653APPC PathWave Automatic Channel 
Response Correction and S-parameter De-embedding license installed.

If there is not a first line header, the default format is GHz, S-parameters, 
and magnitude/angle.
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TIP An s2p example file is included on the MXG. Go to 

 /Examples/simpleAt3GHzInDB.s2p

2. Select Preset > Preset to set the instrument to a known state.

3. In the MXG Output area, set the Frequency to 3 GHz and Power to 
–10 dBm. 

4. Select the Group 1: Signals block to open.

5. Select the Mode dropdown and select Multitone:

6. From the left pane, select Multitone and set:

— Tones to 21 > x1
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— Tone Spacing to 40 MHz

7. Select the General tab > Enable.

8. Close the Signal block by selecting the Home icon, and then select RF Out 
channel number to turn on.

9. On the X-Series Signal Analyzer spectrum analyzer in Spectrum Analyzer 
Mode:

— Select Mode Preset to set Spectrum Analyzer mode to a known 
state.

— Set the Center to 3 GHz
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— Set Span to 1 GHz

10. On the MXG, select the RF Output block > Corrections/De-embedding.
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11. In the Corrections Setup dialog, select Add from File.

12.Select the Up arrow icon to access the Examples folder. 

13. From the Examples folder select simpleAt3GHzInDB.s2p.

Notice that Block B is added in the Correction Setup diagram.
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14. At the top of the display, turn Corrections On. View the results on the 
signal analyzer. Observe how the .s2p file has impacted the signal.

15. Add a third block using the same file name as shown in the steps above. 
Under Block C Properties, set to Embed.
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View the results on the X-Series spectrum analyzer. Notice that the 
corrections are no longer shown. This is because the de-embedded 
corrections applied in Block B cancel the embedded corrections applied in 
Block C.

Using a Spectrum Analyzer to Make the Corrections Measurement

When using a spectrum analyzer, it must be locked to the MXG Frequency 
Reference. This is important because the power measurement can be 
inaccurate due to a narrow resolution bandwidth (RBW) used in the spectrum 
analyzer. Supported Keysight X-Series signal analyzers are:

— N9000A/B CXA

— N9010A/B EXA

— N9020A/B MXA

— N9021B MXA

— N9030A/B PXA

— N9032B PXA

— N9040B, N9041B, or N9042B UXA

On the MXG:

1. Connect the Ref Out to the N90x0A/B Ext Reference In. 

2. Connect cable or DUT between the MXG RF Out and the signal analyzer 
RF in.

3. Select Preset > Preset to set the instrument to a known state.

4. Set the Frequency to 3 GHz and Amplitude to –10 dBm.
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5. Select the Signal block to open. 

6. Select the Mode dropdown and select Multitone.

7. Select the Multitone tab from the left panel and then, configure the signal 
to have 501 Tones with 1.5 MHz Tone Spacing. 

8. Select the General tab > Enable.

9. Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

On the Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Spectrum Analyzer mode > Occupied BW Measurement > OBW Results 
View.

2. Set the Center Frequency to 3 GHz and the Span to 1 GHz.

Observe how the fixturing is impacting this signal, including the flatness 
and the total power.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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On the MXG:

1. Select the RF Output block > Corrections/De-embedding tab to open the 
Correction Setup.

2. Select Block A to highlight > Add from Measurement to open the Measure 
Corrections Block Wizard. 

3. Connect the power sensor (in this case, the X-Series signal analyzer) as 
shown in the diagram below. After reading the overview, select Next to 
move to the Configure Sensor setup.

4. In the Configure Sensor setup, select the Device Type dropdown and 
select Spectrum Analyzer.

5. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 2.5 GHz, Stop Freq 3.5 GHz, Amplitude to the highest 
power used in your measurement (For this example, -10 dBm, which we 
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already set in the main window. If you change the value here, it will update 
the value in the main measurement window.) and Number of Steps to 
101 > x1.

6. Set Connection Type to LAN, enter the LAN Address and set the Protocol 
parameters to HiSLIP, and then select Test Connection. 

7. Once you are successfully connected, select Next to move to the Measure 
Corrections step.

8. Select Measure Correction Data. 
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During the measurement, the MXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. It 
will take some time to measure all 101 points, and the progress is 
indicated by the blue bar. You can watch the signal analyzer as it steps 
through this process.

The measurement results are saved to a csv file using an automatically 
generated file name. 

9. When the measurement is complete, select Finish, then set Corrections 
On.

The output csv file is set to Block A.
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Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

10. On the signal analyzer, Restart the (on the left corner of the user 
interface) measurement (because it is applying averaging). Observe how 
the measured corrections impacted the signal. You can easily toggle 
Corrections on and off on the MXG to see the difference. 

Using a Power Meter to Make the Corrections Measurement

The following USB power sensors can be used for the power measurement.

— U8487A-CFG007

— U8485A-CFG006

— U2000A

— U2001A

— U2002A

— U2004A

— U2000B

— U2001B

— U2000H

— U2001H

— U2002H
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On the MXG:

1. Connect the MXG 10 MHz Out to the N90x0A/B Ext Reference In.

2. Select the RF Output block > Corrections/De-embedding tab to open the 
Correction Setup.

3. Select the A block (to highlight), then Add from Measurement to open the 
Measure Corrections Block Wizard. 

4. Connect the power sensor as shown in the diagram below then select 
Next.

5. Select Next to go to Configure Sensor dialog and select the Power 
Measurement Device dropdown > Power Meter.
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6. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 2.5 GHz, Stop Freq 3.5 GHz, Amplitude to the highest 
power used in your measurement 5 dBm, and Num Steps to 20.

7. Select the Connection Type to USB, and then specify the Device and VISA 
Address. 

8. Select Test Connection to verify connectivity, and then select OK then 
Next to continue.

You can also calibrate and zero out the power sensor before measuring 
corrections.

9.  Select Next to go to the Measure Corrections dialog and select Measure 
Correction Data. 

During the measurement, the MXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. The 
measurement results are saved to a csv file using an automatically 
generated file name. 
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10. Select Finish. The output csv file is set to Block A.

Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

11. Select Corrections On to apply.
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Using the equivalent SCPI commands

Using a spectrum analyzer to make the corrections measurement

On the MXG:

SYSTem:PRESet

Set the power level to the highest level used in your measurement.

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice SANalyzer

CORRection:FLATness:STEP:STARt 5GHZ

CORRection:FLATness:STEP:STOP 7GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE SOCKets

Set the LAN address and protocol parameters for your spectrum analyzer.

CORRection:SANalyzer:COMMunicate:LAN:IP "192.168.1.5"

CORRection:SANalyzer:COMMunicate:LAN:PORT 5025

CORRection:FLATness:CALibrate

CORRection ON

Using a power meter to make the corrections measurement.

On the MXG:

SYSTem:PRESet

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice PMETer

CORRection:FLATness:STEP:STARt 2.5GHZ

CORRection:FLATness:STEP:STOP 3.5GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE USB

CORRection:PMETer:COMMunicate:USB:DEVice “instr0”

[Optional] CORRection:PMETer:CALibrate 

[Optional] CORRection:PMETer:ZERO 

CORRection:FLATness:CALibrate

Use query CORRection:PMETer:COMMunicate:USB:LIST? for a list of all 
connected USB devices. 
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CORRection ON

Adding fixture blocks using s2P files

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 3GHZ

RF1:POWer:AMPLitude -20dBm

SIGNal1:MODE MTONe

SIGNal1:MTONe:ARB:NTON 21

SIGNal1:MTONe:ARB:FSP 100MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 3GHZ

FREQuency:SPAN 1GHZ

On the MXG:

Set the path to the s2p data as block 2 (you can use 1 through 4).

CORRection:BLOCk2:FILE "FixtureChannel2"

CORRection:BLOCk2 ON

Add block C with the same file.

CORRection:BLOCk3:FILE "FixtureChannel2"

Change Block C to Embed.

CORRection:BLOCk3:APPLy EMBedding

CORRection:BLOCk3 ON
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3 5G New Radio (NR) Measurements

This section includes the following topics:

— “5G Waveform, EVM, and ACP Analysis” on page 96

— “Setting Up Triggers on the Signal Analyzer using 5G NR Mode” on 
page 96

— “Setting Up a 1 CC 3.5 GHz EVM Measurement” on page 98

——“Demodulate the Waveform Using the X-Series Signal 
Analyzer Embedded Application” on page 101

——“Demodulate the Waveform Using the 89601B VSA 
Software:” on page 106

— “Setting Up a 1 CC 3.5 GHz ACP Measurement” on page 111

——“Setup the MXG:” on page 111

——“Demodulate the Waveform Using the X-Series Signal 
Analyzer Embedded Application” on page 101

——“Demodulate the Waveform Using the 89601B VSA 
Software:” on page 106
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5G Waveform, EVM, and ACP Analysis 
The MXG enables 5G testing with a low error vector magnitude (EVM). The 
MXG has extremely good EVM at high power levels. However, not all signal 
analyzers can capture this low value. We will use the X-Series signal analyzer 
with the 5G NR X-Series application and the VSA software to observe EVM and 
adjacent channel power (ACP). 

Setting Up Triggers on the Signal Analyzer using 5G NR Mode

Setting Up Triggers on the X-Series Signal Analyzer

Using the graphical user interface

1. On the signal analyzer, select Mode/Meas > 5G NR & V2X mode. 

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR V2X Mode > Modulation Analysis 
Measurement.

4.  From the Menu Panel (on the top right of the display), select Trigger and 
set Select Trigger Source to External 1 and Trigger Level to 1 V.

Refer to “Equipment Setup” on page 9 for connecting the instruments.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument:CONFigure:NR5G

SYSTem:PRESet

Change the current window to 5G NR Modulation Analysis Measurement Mode

INSTrument:CONFigure:NR5G:EVM

TRIGger:EVM:SOURce EXTernal1

TRIGger:EXTernal1:LEVel 1V
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Setting Up a 1 CC 3.5 GHz EVM Measurement 

On the MXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 3.5 GHz and Power to 
5 dBm.

3. Select Group 1: Signals block to open.

4. From the Waveform tab on the left side of the display, choose File Select 
to navigate to the Waveforms folder.

5. Select the Up arrow icon to access the Examples folder. 

6. Open the Examples folder and highlight 
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.wfm, 
then Select. 

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer using 5G NR Mode” on page 96. 
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7. Select the General tab > Enable.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

9. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 960 MHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
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resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

10. Close the Adjustments Setup by either selecting the Back or the Home 
icon at the top of the display.

11. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

12. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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Demodulate the Waveform Using the X-Series Signal Analyzer 
Embedded Application

1. On the signal analyzer, select Mode/Meas > 5G NR & V2X mode. 

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR V2X Mode > Modulation Analysis 
Measurement.

4. Select Recall (If accessing the signal analyzer remotely, select the Folder 
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup 
> Recall From > 

You will need to copy the setup files to the X-Series Signal Analyzer or the 
PC running the VSA application. Go to:

https://www.keysight.com/us/en/lib/software-detail/instrument-firmwar
e-software/measurement-guide-example-files.html

Select Download and wait for the zip file to finish downloading to your 
Downloads folder. This may take a few minutes as it is a 2 GB file. You will 
find the setup file(s) under the applicable Measurement name. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
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5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC punctured_34.scp

Recall

5. Select Frequency > Carrier Reference Frequency > 3.5 GHz.

6. Select Meas Setup > Advanced tab > Advanced Demod Setup and ensure 
that RF for Phase Compensation Auto is not selected and the value is 0 Hz. 
Close the Advanced Settings table.

7. Select the Settings tab > Optimize EVM.

The Optimize EVM function automatically sets the combination of 
preamplification, mechanical and electronic attenuation, and IF gain based 
on the measured signal peak level. 

EVM should be less than 1%. 
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Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 3.5GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

Navigate to the desired waveform file.

SIGNal1:WAVeform “/Examples/ 
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC punctured.wfm ”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

You will need to copy the setup files to the X-Series Signal Analyzer or the 
PC running the VSA application. Go to:

https://www.keysight.com/us/en/lib/software-detail/instrument-firmwar
e-software/measurement-guide-example-files.html

Select Download and wait for the zip file to finish downloading to your 
Downloads folder. This may take a few minutes as it is a 2 GB file. You will 
find the setup file(s) under the applicable Measurement name. 

https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
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MMEMory:LOAD:EVM:SETup CC0, 
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\5GNR_1CC_FR1_30kHz SCS_100MHz_256QAM_DCpunctured.scp”

EVM:CCARrier0:TIME:LENGth:SEARch 10ms

EVM:CCARrier0:TIME:LENGth:RESult 2

EVM:CCARrier0:FRAMe:TRIGger ON

EVM:CCARrier0:DC:PUNCture ON

EVM:CCARrier0:PHASe:COMPensation:AUTO OFF

EVM:CCARrier0:PHASe:COMPensation:FREQuency 0 Hz

EVM:OPTimize
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Demodulate the Waveform Using the 89601B VSA Software:

1. Open the VSA software by selecting Mode Meas > Launch VSA. 

2. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

3. Select File > Recall > Recall Setup and navigate to 
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC punctured.setx 

4. From the toolbar, select the Pause Icon. 

Pausing the measurement will help speed up the setup time.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

You will need to copy the setup files to the X-Series Signal Analyzer or the 
PC running the VSA application. Go to:

https://www.keysight.com/us/en/lib/software-detail/instrument-firmwar
e-software/measurement-guide-example-files.html

Select Download and wait for the zip file to finish downloading to your 
Downloads folder. This may take a few minutes as it is a 2 GB file. You will 
find the setup file(s) under the applicable Measurement name. 

https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
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5. From the menu bar, select Input > Trigger and set Style to External and 
Level to 1.0 V.
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6. Select the Extensions tab and change the External Trigger location to 
Trigger 1 In (if using an N9040B with Option H1G, select Trigger 3) and 
Phase Noise Optimization to Best Wide Offset. 

7. From the toolbar, select the Auto-Range dropdown and select EVM-Table 
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM.

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

8. Select the Auto-Range icon to run the measurement for EVM optimization. 
This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

MMEMory:LOAD 
“D:Users\Instrument\Documentts\NR5G\data\NR5GEvm\Carrier 
Setup\5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC 
punctured.setx”

INITiate:PAUSe

INPut:TRIGger:STYle "EXTERNAL"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

Set the 5G NR Demod Result Length to 10 Subframes:

NR5G:RLENgth 10

NR5G:SUBFrame:INTerval 2

Set the Acquisition Mode to “Frame Trigger is Present”

nr5g:FRAMe:TRIGger:ENABled 1

You will need to copy the setup files to the X-Series Signal Analyzer or the 
PC running the VSA application. Go to:

https://www.keysight.com/us/en/lib/software-detail/instrument-firmwar
e-software/measurement-guide-example-files.html

Select Download and wait for the zip file to finish downloading to your 
Downloads folder. This may take a few minutes as it is a 2 GB file. You will 
find the setup file(s) under the applicable Measurement name. 

https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
https://www.keysight.com/us/en/lib/software-detail/instrument-firmware-software/measurement-guide-example-files.html
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Setting Up a 1 CC 3.5 GHz ACP Measurement

Setup the MXG:

1. Select Preset > Preset to set the MXG to a known state.

2. Set Frequency to 3.5 GHz and Amplitude to 0 dBm. 

3. Select Group 1: Signals block to open.

4. From the Waveform tab on the left side of the display, choose File Select 
to navigate to the Waveforms folder.

5. Select the Up arrow icon to access the Examples folder. 

6. Open the Examples folder and highlight 
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC Punctured.wfm, 
then Select. 

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 9 and “Setting Up Triggers on the Signal 
Analyzer using 5G NR Mode” on page 96.
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7. Select the General tab > Enable.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

9. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

10.For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. Select Mode/Meas > 5G NR & V2X Mode > ACP Measurement.

3. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the MXG:

SYSTem:PRESet

RF1:FREQuency:CW 3.5GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform 
“/Examples/5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DCPunctured.
wfm”

SIGNal1 ON

DM:OPTimization:CHANnel ACP

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

INSTrument:CONFigure: NR5G:ACP

CCARrier:REFerence 3.5GHZ

ACPower:CORRection:NOISe ON
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4 Other X-Series Signal Analyzer Measurements 

— “Using the X-Series Analyzer’s SCPI Recorder Function” on page 116

— “Using Real-time Spectrogram Streaming (Option RRT) for N9032B and 
N9042B” on page 129
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Using the X-Series Analyzer’s SCPI Recorder Function 
The SCPI Recorder feature allows you to view active recording content, and 
edit the content. Right-click or touch and hold on any UI control to display a 
menu allowing you to record the SCPI associated with the control. You can also 
record a series of commands. These commands can be viewed and edited 
directly, or you can also play, save/recall for future use.

For this example, we will generate a simple 5G NR 100 MHz signal.

Using the graphical user interface

On the MXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 3.5 GHz and Power to 
0 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4. Select 5G NR.
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5. Select the Carrier tab > DL Test Model and set Test Model to 
NR-FR1-TM3.1b, leave the remain settings at their default values, and 
select OK. 
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6.  Select the Waveform tab, then Generate to generate the Waveform, and 
then select Home to exit the setup panel. 

7.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode/Meas > 5G NR &V2X Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known 
state.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 



 N5186A MXG and X-Series SA Measurement Guide                                                                                        119  

Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer’s SCPI Recorder Function

3. From the Menu Panel (or the Screen tab), select Mode/Meas > 5G NR & 
V2X Mode > Modulation Analysis Measurement > OK. 

4. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

— Touch and hold the Carrier Reference Frequency function for at 
least one second on the touch screen or if using a mouse pointer 
and right click to open the menu.

— Select Show SCPI Command.

The SCPI command for this function is displayed in the dialog box.

Select Copy to copy the current SCPI command string for further 
use.

If you use Windows Remote Desktop or a VNC viewer with clipboard 
synchronization enabled, you can copy the SCPI command into the 
clipboard. This makes SCPI commands available on the fly via a 
simple copy/paste operation.

— Select Help on this setting to open the SCPI syntax document page.
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You will see the background information for that setting including 
allowed values, SCPI command and examples, and other useful 
information. 

To Start Continuous SCPI Recording: 

The SCPI Recorder supports an automatic mode of operation. In this mode, a 
series of manual operations can be added to the list automatically without any 
further user activity. You can start the recording process by enabling the 
Continuous SCPI Recording, then disable it to stop recording after completing 
all configuration steps. This is normally the best choice for fast and convenient 
SCPI list recording. 

There are two ways to start continuous SCPI recording:
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— From the System Settings > SCPI Recorder.

— From the context sensitive menu of the function key.
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1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. For this example, select the System Settings icon (Gear wheel on top right 
of the display) > SCPI Recorder > Continuous SCPI Recording On. Close 
the System Settings window by selecting the "X" at the top of the window.

3. Select Mode/Meas > 5G NR &V2X Mode > Modulation Analysis 
Measurement > Normal View > OK. 

4. Select Frequency > Carrier Reference Frequency and set to 3.5 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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5. Select Meas Setup > Meas Standard > RB Alloc Preset > DL NR-TM3.1 > 
DL NR-TM3.1b (1024QAM) > OK.

6. Select Apply Preset (to All CCs).
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7. Select the Settings side tab and select Optimize EVM.

8. Select Sweep > Sweep/Meas to Single > Restart.
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9. Select the System Settings icon (Gear wheel on top right of the display) > 
SCPI Recorder > Continuous SCPI Recording Off. Close the System 
Settings window by selecting the "X".

Manual Recording, Edit, Save and Play Functions

The SCPI Recorder supports manual recording of a list consisting of SCPI 
commands comprising any number of parameter variations when Continuous 
SCPI Recording is off. In this mode, the user can decide which SCPI commands 
should be added to the SCPI list. This mode of recording is helpful if a certain 
configuration must be figured out, and you only want to record the final, 
correct settings and not every variation or keystroke. 
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1. Touch and hold the any function for at least one second on the touch 
screen or if using a mouse pointer and right click to open the menu and 
select Add to SCPI Recorder. For this is example we will change EVM 
Optimization Method to Iterative.

2. To view the newly added command, go to System Settings icon (Gear 
wheel on top right of the display) > SCPI Recorder.
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From the SCPI Recorder provides several operations to edit the SCPI list 
you created. You can Play, Copy, Move Up or Down the selected SCPI 
command, Delete the command, or Delete All the commands.

The recorded SCPI list can be exported as a script file in .TXT format via 
the Save/Recall function at the bottom of the main window. 
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There are two ways to playback SCPI commands. One is recalling from a 
script file. And another one is pressing the 'Play' button in 'SCPI Recorder' 
tab view. 

Recalling SCPI script file allows you to play back a series of operations in 
the same or another instrument, which helps you setup complex 
measurement scenarios quickly and easily.

To recall the SCPI recording, go to Save/Recall and navigate to the saved 
file.
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Using Real-time Spectrogram Streaming (Option RRT) for N9032B 
and N9042B

Overview

Real-time Spectrogram Streaming combines the high-speed capture 
capabilities of RTSA equipped analyzers with the convenient flexibility of 
post-processing, allowing you to set their desired measurement parameters 
such as: center frequency, span, and acquisition time and then stream the 
resulting gapless spectrogram data to binary files. This improves the storage 
capacity of captured slices by 8x. The saved binary files can be used for 
customized post-processing. A MATLAB program (RTSA viewer) is provided to 
introduce users to post process analysis of the saved binary files. In this 
procedure you will learn how to set up Real-time Spectrogram Streaming and 
how to use the Rtsa viewer to view your captured spectrogram slices.

Equipment:

— N5186A MXG or M9484C VXG

— N9032B PXA or N9042B UXA with Option RRT

— 3.5 mm female to female cable

— For a mmWave signal analyzer, 2.4 mm female to 3.5 mm male adaptor 

For a Wave signal analyzer, Type N male to 3.5 mm female

Using the 3.5 mm cable and the 3.5 mm to 2.4 mm (or Type N) adaptor, 
connect the MXG/VXG RF output to the RF input of the PXA/UXA.
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On the MXG/VXG Signal Generator:

Start by generating a sweeping frequency modulated signal for its distinctive 
formation in the spectrogram screen. Note: This is purely an example for 
simplicity and demonstrative purposes.

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 5 GHz and Power to -10 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the 
corresponding RF Output Block.

3. Select the Out Mod block to open.

This is purely an example for simplicity and demonstrative purposes. This 
process can be used for other signals such as 5G NR and WLAN.
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4. In the Output Mode window, select the right arrow at the bottom of the 
display to select choices 5-8, then select the FM 1 arrow at the far left side 
of the window.

5. In the Output Modulation FM 1 window, set:

— Frequency to 1 kHz

— Deviation to 100 MHz

— Toggle FM 1 on

— select the Home icon at the top of the screen
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6. Select the RF Output block.

7. In the RF Output block, set:

— List/Step Sweep tab

— Edit Step Sweep

8. In the Step Sweep window, set:

— Frequency Start to 5 GHz

— Frequency Stop to 6 GHz

— Power Start to -10 dBm

— Step Dwell Time to 500 ms

— Linear Frequency Step to 250 MHz
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— select the Back arrow to return to Output 1: RF Output.

9. Select List/Step Sweep >toggle Enable Sweep to turn on.

10. Select the Home Icon and turn RF Output On.

On the PXA or UXA Signal Analyzer:

Now that the signal has been created, we can use RTSA with Option RRT to 
capture the signal into bin files.
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1. Select Mode/Meas > Real-Time Spectrum Analyzer Mode > Spectrum & 
PvT Measurement.

2. Select Mode Preset to set Real-time Spectrum Analyzer mode to a known 
state.

3. Select Mode/Meas > Real-Time Spectrum Analyzer Mode > Spectrum & 
PvT Measurement > Spectrogram View.

4. Select Frequency and set Center Frequency to 5.5 GHz and Span to 2 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 



 N5186A MXG and X-Series SA Measurement Guide                                                                                        135  

Other X-Series Signal Analyzer Measurements
Using Real-time Spectrogram Streaming (Option RRT) for N9032B and N9042B

Notice the acquisition time is preset to 30 ms and how changing the 
acquisition time affects the spectrogram.

5. On the lower right area of the Spectrum window, select Acq Time and 
change to 100s.
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Notice how the FM signal is now resolved.

6. At the bottom of the display, select the Windows icon > Keysight 
Connection Expert.
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7. In the Keysight Connection Expert window’s left pane, select Keysight 
Technologies localhost and then Interactive IO.

8. In the Command area, type in the following commands:

— STR:TYPE FINite > Send Command

— STR:TYPE? > Send Command

— STR:LENGth 100,000 > Send Command

— STR:LENGth? > Send Command

— STR:FNAMe "sweptfmsignal" > Send Command

— STR:FNAMe? > Send Command

— STR:STARt > Send Command

Once the Start command is sent, the analyzer will execute the number of 
iterations and store the resulting bin file in Documents > RTSA > data > 
results.
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9. From the bottom of the X-series app, select Windows File Explorer and 
navigate to Documents > RTSA > data >results.

These bin files can now be uploaded to the RtsaViewer for processing and 
analysis. You can open RtsaViewer locally on the analyzer or transfer the 
files to another PC equipped with the RtsaViewer.
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Using the Rtsa Viewer

1.  In the Windows search bar, type RtsaViewer and Open the application.
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2.  In the RtsaViewer, select Browse and navigate to your bin files. 
(Documents > RTSA > data >results). Select sweptfmsignal_0.bin > 
Open.

The RRT Visualization Tool window may be hidden by the X-apps display. 
If you cannot see the visualization tool, select Alt > Tab to position it in 
front of the X-apps display.
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3.  Select Process File Series to generate the file table.

4. Select Display Options and set Consecutive Slices to 4096 to view the 
sames displays as shown in the pictures below.

Display Option Settings

The Display Options tab contains settings to customize the display.
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Preset Display Angles Area

— Spectrogram View - plots the selected slices with axes of time in seconds 
and frequency in Hz.
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— 45° 3D View - plots the selected slices on a 45-degree rotated, 
three-dimensional plot with axes of power in dBm, time in seconds, and 
frequency in Hz.
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— dBm vs Freq View - plots the selected slices with axes of power in dBm and 
frequency in Hz, showing the power distributed over the spectrum.

— dBm vs Time View - plots power in dBm over time in seconds.
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Selected Slices Area

The Selected Slices menu has adjustable settings including Starting Slice, 
Consecutive Slices, Max Consecutive Slices, and Max Slices per Chunk. 
Adjusting these settings allows for complete control of the signal slices you 
want to view. 

Adjust Axis View

The Adjust Axis View can be used to alter the Axis of the viewable plot in time, 
frequency, and power without affecting the Selectable Slices settings.

FMS Tab

The FMS tab allows you to isolate signals by specifying corner bounds of an 
upper mask, then selecting Run FMS. Any signal considered inside the mask 
will be shown in the Frequency Mask "Search" hits table. While the upper 
mask includes a default of 4 bounds, mask bounds may be added or removed 
by right clicking the Upper Mask Settings table. 

To render and display specific events, highlight the FMS hit you wish to see 
plotted. The example program's display will update to render the capture 
portion including the signal that triggered the mask (not the isolated signal 
passing over the mask alone). 
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Additionally, at the bottom of the FMS tab, the Display of the Selected Event 
can be customized between three display options:

— Beginning shows the moment the signal entered the mask. 

— Ending shows the moment the signal left the mask.

— Entire shows the full duration between when the signal entered and exited 
the upper mask

1. Set the Frequencies to 5.3 GHz, 5.4 GHz, 5.9 GHz, and 6.0 GHz.

2. Check for signals that are found using the mask.

Playback Tab

The Playback tab provides you with a quicker method for visually parsing data. 
Given a specified start and end slice within the uploaded capture, displayed 
slices (at a time), and desired additional delay per update in seconds, the 
playback feature will scroll through the provided range, rendering and 
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displaying Displayed Slices on the axes at a given time. This screen will then 
show for some latency + the desired additional delay before updating to the 
next screen; unlike rendered displays generated through Display Options, 
rendering is cleared the moment it leaves the display.

To begin Playback, select the Begin Playback. Playback will continue until 
completion, regardless of the tab you may be on. If for any reason you wish to 
stop the playback, select Cancel Playback, which is only available during an 
active playback. You may monitor the playback's progress relative to your 
uploaded capture through the loading bar.

 Try using the tabs and settings to get a feel for the RTSA Viewer application.
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Conclusion

Option RRT allows you to record RTSA spectrogram slices for post capture 
processing. The option comes with an example program (RTSA viewer) that 
extracts the spectrogram data from the bin files that are created from 
recording. You can create your own applications or build off of RTSA viewer to 
perform in depth signal processing.

Additional Resources

Application note: Real-Time-Spectrogram-Streaming.pdf

https://www.keysight.com/us/en/assets/3124-1730/application-notes/Real-Time-Spectrogram-Streaming.pdf
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5 Custom Modulation Measurements

This section includes the following topics:

— “Using PathWave E7608APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results” on page 150

— “Using the N5186A MXG as an Embedded Reflectometer” on page 156
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Using PathWave E7608APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results

PathWave software tools can be used to create, download, and playback 
waveforms through the MXG.

This example shows you how to create and analyze a 16QAM using the 
embedded PathWave software and then automatically configure the analyzer 
to make the measurement. 

On the MXG:

1. Select Preset > Preset to set the MXG to a known state.

2. In the Output area, set Frequency to 4 GHz and Power to 
0 dBm.

3. Select the Apps block to open the mode selection panel.

4. Select Custom Modulation to enter the custom modulation application.

5. In the Custom Modulation setup, select the Carrier tab.

The MXG must have the E7608APPC Custom Modulation license installed 
and Signal Analyzer Version 2023 A.36.xx or later.
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We will use the default 16QAM constellation for this example.

TIP Use Quick Setups for convenient saving and loading of common 
configurations. Quick Setups are factory supplied configurations and cannot 
be deleted by users.
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6. In the left pane, select Custom ASK & PSK & QAM and set Symbol Rate to 
100 Msps.

7. Select the Waveform tab > Generate. 

Scroll down to the bottom half of the display and select Spectrum to view 
the Waveform.

8.  Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.
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Setup Auto Configure Analyzer 

1. Select the System menu (triple bar tab at the top left of the window) and 
select Configure Analyzer.

2. In the Configure Analyzer setup, click on the Remote Signal Analyzer block 
(on far right) to setup the communication channel to the Keysight X-Series 
Signal Analyzer. 

3. Select the Use Device List checkbox > Configure Device
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Alternatively, you can just enter the device information for a one time use. 
The Use Device List allows you to set up more than one Spectrum Analyzer 
to be used for a channel’s Auto Configuration.

4. In the Device List Manager, select Add and enter a name for your X-Series 
Signal Analyzer:

— Set Connection Type to LAN

— Enter the VISA Address of the analyzer.

— Test Connection

Select the Info icon (Bell shaped icon at top right of the display) to 
view the connection status.
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5. Select the Back Arrow and select Auto Configure Analyzer to send the 
MXG settings to the analyzer. 

6.  View the results on the signal analyzer. 
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Using the N5186A MXG as an Embedded Reflectometer
Traditionally Keysight signal generators, such as the N5182B MXG, have 
automatic level control (ALC) which works great for RMS power across time 
and temperature. The ALC is a closed loop system with feedback from a power 
detector. A challenge with this approach is maintaining amplitude accuracy 
when the generated signal is wide-band and or high crest factor. The ALC does 
not compensate for phase flatness or delay. Keysight's N5186A MXG 
implements a new approach that guarantees amplitude accuracy by aligning 
across frequency and temperature along with advanced temperature control 
compensation. Compensation includes amplitude, phase, and delay. 

A common source of linear error is caused by mismatch of the fixture and 
device under test (DUT). By default, the reference plane is at the test port of 
the MXG and assumes a 50 ohm load is connected, which in many cases is not 
how the test is set up. The effect of linear error affects absolute amplitude 
accuracy, amplitude frequency response (flatness), phase frequency response 
(phase dispersion or deviation from linear phase), and IQ impairments. By 
using the N5186A's embedded reflectometer, the reference plane can be 
moved from the source's RF output to the input of the DUT while also 
generating a match corrected signal. The embedded reflectometer supports 
features such as fixture characterization, DUT S11 measurements, 
corrections/fixture de-embedding, and DUT match correction (by generating a 
match corrected wave). This measurement example will provide detailed steps 
and features of the embedded reflectometer for N5186A MXG.

Test Setup

Definitions

— DUT Input: Targeted plane that the user desires to stimulate the DUT.

— Reference Plane: The endpoint for the MXG’s calibration.

— Fixtures: All electrical components in the signal path between the DUT and 
the MXG.

— Incident Power [dBm]: The incident power the user desires to stimulate the 
DUT.

In general, a DUT is connected to a fixture that is connected to the test port of 
the MXG.

The MXG must have the E7608APPC Custom Modulation license installed 
and Signal Analyzer Version 2024 A.38.xx or later.
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Figure 5-1 Block diagram of general test setup when connecting a DUT to an MXG

Materials

Figure 5-2 Number 1 on material list: N5186A MXG (Any channel configuration is 
acceptable) 

Material Part Number Quantity

1 MXG N5186A MXG - (Any channel configuration is 
acceptable)

1

2 Signal Analyzer N9032B PXA - (Any Keysight Signal Analyzer is 
acceptable)

1

3 ECal Module N7555A - (See “Supported ECal Modules” on 
page 161)

1

4 DUT Mini Circuits ZX60-83LN-S+ 1

5 RF Attenuator Mini Circuits 15542 6 dB 1

6 3.5 mm Coax Cable Any quality male-to-male connector is acceptable 2

7 USB 5 V Connector Used to power the DUT 1
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Figure 5-3 Number 2 on material list: N9032B PXA (Any Keysight Signal Analyzer is 
acceptable) 

Figure 5-4 Number 3 on material list: N7555A ECal Module (See “Supported ECal 
Modules” on page 161) 
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Figure 5-5 Number 4 on material list: Mini Circuits ZX60-83LN-S+ 

Figure 5-6 Number 5 on material list: Mini Circuits 15542 (6 dB attenuator)

Figure 5-7 Number 6 on material list: SMA 3.5mm male to male coaxial cable
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Figure 5-8 Number 7 on material list: USB powered 5V connector 
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Supported ECal Modules
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Configure the Test Setup

Part 1

Begin setting up the equipment to take the first measurement, measuring the 
DUT without fixturing or calibration.

Setup the DUT:

1. Connect the 6 dB attenuator to the DUT's output port. 

To prevent shorting and damage to DUT, ensure USB 5V connector is 
unplugged when attaching power and ground clips to DUT.
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2. Attach the red clip to the +5 VDC pin and the black clop to the GND pin.

3. Connect the MXG RF output to the input port of the DUT. Connect the 
signal analyzer RF input to the other side of the attenuator. The figure 
below shows the RF connection to the MXG and the signal analyzer.

4. Connect the USB 5V to any of the available USB ports on either the 
analyzer or generator.

Generate the Signal:

The signal used in this demonstration is a 500 Msps symbol rate, 4096 Symbol, 
16 QAM signal. 

1. On the MXG, select Preset > Preset to set the instrument to a known state.
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2. On the MXG select the Apps menu > Custom Modulation.

3. In the Carrier menu (left pane) select Custom IQ Selection > Custom IQ 
Type > QAM & ASK & PSK.

4. Select Custom ASK & PSK & QAM > Symbol Rate to 500 Msps.
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5. Select the Filter tab > set Filter to Root Nyquist > Alpha 0.2 > Length 
(symbol) 32.

6. Select Segments > Constellation 16QAM > NumberOfSymbols 4096.

7. Select the Waveform menu (left pane) and select:

— Basic tab

— Enable User Defined Sample Ratio

— Sample Rate to 1 GSa/s

— Number of Frames to 1
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Select Generate. 

8. Scroll down to the bottom half of the display and select Spectrum to view 
the Waveform.

9.  Select the Home icon and set Frequency to 6.5 GHz and Power to 
-20 dBm. 

10. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.
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Set up the Signal Analyzer:

To characterize the DUT we need to demodulate the signal we are sending 
through it.

The following steps can be done quickly by taking advantage of the Configure 
Analyzer function on the MXG. The MXG and Signal Analyzer must be on the 
same LAN network to use the Configure Analyzer function to work. If this 
criterion is met, follow these three steps to quickly configure your Signal 
Analyzer.

1. Select the System menu > Configure Analyzer.

2. Select Click to change connection.

3. In the Remote Instrument window, 

— set Connection Type to LAN

— Enter the IP address of the signal analyzer

— select Test Connection to verify proper connection
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— select the navigation button (left arrow) to return to the Configure 
Analyzer window.

4. Select Auto Configure Analyzer to send the MXG settings to the analyzer. 

5.  View the results on the signal analyzer. 
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Manually Configure the Signal Analyzer

When not using Auto Configuration, follow these steps to manually configure 
the Signal Analyzer.

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Vector Modulation Analyzer mode > Digital Demod > OK.

2.  Select Mode Preset to set the Vector Modulation Analyzer mode to a 
known state.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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3. Select Frequency and set Center Frequency to 6.5 GHz.

4. Select BW > and set Info BW to 1 GHz.
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5. Select Meas Setup > Meas Time > set Meas Interval to 4096 symbols.

6. Select Meas Setup > Demod > set Symbol Rate to 500 MHz and 
Points/Symbol to 4.
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7. Set Meas Filter to Root Raised Cosine > Ref Filter to Root Raised Cosine > 
Filter Alpha to 0.2.
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8. Select Modulation Format to open the Modulation Format window and 
then select QAM Formats > 16 QAM. Select OK to close the Modulation 
Format window.

Take the DUT Measurement

Now that the source is set up to demodulate the 16QAM signal, you can 
measure the unequalized EVM in dB and channel response in both phase and 
magnitude. This will give a baseline for how the DUT preforms without fixturing 
and calibration. 

1. On the MXG, set RF Out to On by selecting the numbered channel 
indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel MXG.

2. On the Signal Analyzer, select Meas Setup > Demod tab > Advanced 
Setup and set Report EVM DB to On. Close the Advanced Setup Window.
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3. Record the EVM in dB. For this example, 21.60 dB rms.

4. At the top of the display, select the Equalizer menu and toggle Equalizer 
On. The Meas Interval was already set to 4096 in a previous step. 
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5. On Measurement window 2 (top right), select the dropdown and select 
Data > Response > Ch Freq Response > OK.

6. On Measurement window 2, set. 

— Scale/Div to 1.00 dB

— Ref Value to 5.00 dB
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— Width to 500.000 MHz
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7. Select Measurement window 3 (bottom left) dropdown menu and select 
Data > Response > Ch Freq Response > OK.
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8. On Measurement Window 3, select Format > Wrap Phase to measure the 
phase response in Measurement window 3.

9. On Measurement Window 3, set:

— Scale/Div to 2.00 deg

— Ref Value to 10.00 deg 
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— Width to 500 MHz

Part 2 

Use the ECal module to de-embed the cable or test fixture.

Characterize the Fixture

To characterize the fixture, an ECal module is used to generate an .s2p file of 
the fixture. 

— Do not set the power over ECal's damage levels. Refer to the data sheet 
for your specific ECal module.
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1. On the MXG, turn RF Output Off.

2. Disconnect the input of the DUT and connect the same fixture to Port A of 
the ECal module.
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3. Select the RF Output block to open.

4. In the RF Output dialog box, select the Corrections/De-embedding tab > 
Add Fixture > Block B > Characterize.

5. Set:

— Start Frequency to 10 MHz 

— Stop Frequency to 8 GHz

— Number of Points to 201

—  ECal Port to A

— Power (Total RMS) to -20 dBm

— IF Bandwidth to 1 kHz
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— Run Measurement 

6. When the measurement is complete, Disconnect the fixture from the ECal 
module and connect the fixture back to the input of the DUT.

7. Select the Home icon and turn RF On.
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8. Select the RF Output block > Corrections/De-embedding tab > 
Corrections On > Enable.

9. On the Signal Analyzer, at the top of the display, select the Equalizer 
menu and toggle Equalizer Off to take and unequalized measurement of 
the EVM with fixture de-embedding enabled.
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10. Toggle the Equalizer to On and select Equalizer Reset to take the 
equalized measurement.

Generate an 1.s1p File

Start by generating an .s1p file using embedded reflectometer to enable DUT 
match correction and take unequalized EVM measurements and channel 
response for magnitude and phase. Compare results to the two previous DUT 
measurements. 

1. On the MXG, select RF Output block > Corrections/De-embedding tab > 
DUT block > Add from Measurement.
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2. To generate the .s1p file, set:

— Start Frequency to 5.5 GHz

— Stop Frequency to 7.5 GHz

— Number of Points to 201

— Power (Total RMS) to -20 dBm

— IF Bandwidth to 1 kHz

— Run Measurement

3. Select the Back arrow icon to return to the previous window and ensure 
Enable is selected. 
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4. Take an unequalized measurement of the EVM with fixture de-embedding 
and DUT match corrections enabled. 
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5. Toggle the Equalizer to On and select Equalizer Reset to take the 
equalized measurement.
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Summary

The embedded reflectometer allows easy fixture characterization without the 
use of a Vector Network Analyzer. By characterizing the fixture, corrections can 
be applied to move the reference plane to the input of the DUT. The embedded 
reflectometer can also be used to preform DUT match correction. By making an 
S11 measurement, the reflection can be characterized and therefore corrected, 
allowing for better channel response. In this demonstration you can see the 
increase in performance in real time. In this particular setup the measured 
unequalized EVM goes from -21.60 dB rms to -25.84 dB rms when 
characterizing the fixture and applying corrections. A further increase in 
performance can be seen from preforming DUT match correction. In this 
example, the unequalized EVM goes down to -32.08 dB rms. With both 
correction types applied the unequalized EVM improves by 10.48 dB rms. This 
increase in performance is also embodied in the channel response. The 
channel response in magnitude and phase goes from 3 dB peak-to-peak for 
magnitude and 10 degrees peak-to-peak for phase to ~1 dB peak-to-peak for 
magnitude and ~3 degrees peak-to -peak for phase after applying corrections. 
Using the embedded reflectometer to characterize a fixture and a DUT 
improves station-to-station reproducibility allowing for greater confidence in 
test results.
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